Forum home Getting pregnant Conception & fertility problems

Is it implantation bleeding or my period?

Here's a little background info:

So this month i started my birth control (28 day pill) on a friday. I had been taking it every day at 5 p.m. Except for one occasion. I had slept over my boyfriends house and had to run home at 9 p.m. because i had forgotten my pills. I figured i was only going to be over there until around noon the next day. Well the next day we ended up going to a family get together and we happened to be there very late. Then my roommate was having a bonfire at her job, and to make a long story short, i got a little too intoxicated to remember my birth control pills when i got home. I finally took that days pill at around 8 or 9 a.m. the next day.

Flash foward to now, about 3 weeks later. I had been feeling very sick. If i ate anything with a little bit of spice in it I would feel sick for hours. Everything has been giving me gas. I have a metal taste in my mouth, along with a slew of other symptoms i hadn't had before. This is where the TMI information comes in. I was supposed to start my period on the 9th of September, it is now the 12th. Around the 6th i thought i was getting my period, i felt 'wet' down there. I went to the bathroom and wiped and it was absolutely clear. no odor, no color. nothing. but it felt like i was leaking 24/7. Now today i felt the same thing but i was getting tiny cramps. (Nothing compared to my usual period cramps. They are probably a 9 on a scale of 1 to 10. And the cramps i was having earlier were about a 2 at most). 

I go to the bathroom and wipe and i see a yellowish discharge with a brown tint. About an hour or so later when i went to the bathroom and wiped it was light brown. A while later when i checked it was a dark brown and there was a lot of it. So about 2 hours ago (about 5 after i first noticed any type of discharge) it became a deep red. there wasnt a lot of it but there was also a tiny clot that looked black. I thought this was my period starting so i put a tampon in. But i wasn't getting any type of cramps so an hour later i took it out and it was black. and when i say black i mean black. there was barely enough of it to cover half of the exterior of the tampon, but the color scared me. I kept the tampon out and went in about 30 minutes ago and it returned to a light brown and barely even noticable when i wiped. 

im just getting over a cold and ive been coughing a lot, and whenever i cough i get cramps (about a 4) right over where i believe my ovaries would be. the cramps last for less than 30 seconds, but im still concerned.

I was planning on taking a pregnancy test on the 19th (a week after my missed period) but now i dont know if i should wait a week from today of even take one.

any advice you have would be extremely appreciated.

Sign In or Register to comment.